编辑框 - 插入文本
Q:编辑框EX1.插入文本 / 指定位置
关键代码:A2W()

子程序名 返回值类型 公开 备注
__启动窗口_创建完毕
编辑框EX1.插入文本 (1, A2W (“测试”))

i本程序使用的支持库列表
ExuiKrnln (未知的支持库)
点击此处复制代码
.版本 2
.支持库 ExuiKrnln

.子程序 __启动窗口_创建完毕

编辑框EX1.插入文本 (1, A2W (“测试”))

为了更好方便调用,已为您转换为子程序!

子程序名 返回值类型 公开 备注
A2W 字节集
 
参数名 类型 参考 可空 数组 备注
Ansi文本 文本型
变量名 类型 静态 数组 备注
len 整数型 单位: Word
Unicode字节集 字节集  
len = MultiByteToWideChar (936, 0, Ansi文本, -1, {  }, 0)
Unicode字节集 = 取空白字节集 (len × 2)
MultiByteToWideChar (936, 0, Ansi文本, -1, Unicode字节集, len × 2)
返回 (Unicode字节集)
点击此处复制代码
.版本 2

.子程序 A2W, 字节集, 公开
.参数 Ansi文本, 文本型
.局部变量 len, 整数型, , , 单位: Word
.局部变量 Unicode字节集, 字节集

len = MultiByteToWideChar (936, 0, Ansi文本, -1, { }, 0)
Unicode字节集 = 取空白字节集 (len × 2)
MultiByteToWideChar (936, 0, Ansi文本, -1, Unicode字节集, len × 2)
返回 (Unicode字节集)

声明:
1本站鼓励用户发布原创内容,但并不保证每个人都遵守这一点,若内容侵犯了你的权益可联系管理员删除!
2本站资源,除文章特别指明外,均限定下载者本人使用,禁止二次 转载 传播 分发!
3本站资源多为第三方用户投稿,大家下载资源前仔细甄别需求与其描述是否可达预期 除非较明显的与说明不符资源外的纠纷尽量与作者点对点直接解决
4资源提供者发布作品请提供作品详细说明 与 截图 源码作品若引用了 其它模块或依赖请诚实说明 明细与版本!以及依赖是否开源。尽量做到资源下载后 可以直接使用与运行
5本站资源会员享受折扣 开一个吧只有这个才是站长能拿到手的